Navigation

Pligg Support

RSS Importer (version 2.0) on Pligg CMS 2.0 (RC1?) does not import RSS.

After I setup a RSS feed, I click the feed import. Url is like blow.

http://pligg.example.com/module.php?module=rss_import_do_import&override=1

It shows an error "Feed not fully setup, skipping".
Debug print SQL shows the SQL "select * from pligg_feed_link where feed_id = 1" that returns NULL.

The pligg_feed_link table doesn't have any data.

line 29 in rss_import/templates/import_fields_center.tpl

$Feed_Links = $RSSImport->get_feed_field_links($feed->feed_id);

$Feed_Links is NULL.

Around line 69 in class.rssimport.php

function get_feed_field_links($feed_id=0){
global $db;
if(!isset($feed_id)){$feed_id = $this->FeedId;}
$sql = "select * from " . table_prefix . "feed_link where feed_id = " . $
feed_id;
//echo "" . $sql . "";
$feed_field_links = $db->get_results($sql);
return $feed_field_links;
}

Thank you in advance


I'm using arabic on my Pligg and it's automatically RTL. All looks good so far except the comments area.

They don't look threaded. Please check attachments to understand what I'm trying to describe.

I changed the float of "comment-left" to right instead of left (comment2.png) but they still don't look threaded.

Any suggestions?
I would like to know how to contribute and report bugs? for example, RSS Importer.


There are some bugs in RSS Importer.

[02-Aug-2013 02:02:56 Europe/Berlin] PHP Warning: Table 'db.pligg__feeds' doesn't exist in /pligg-cms/libs/db.php on line 479
[02-Aug-2013 03:12:38 Europe/Berlin] PHP Warning: Table 'db.pligg_files' doesn't exist in /pligg-cms/libs/db.php on line 479


templates/import_fields_center.tpl:
$sql = "UPDATE `" . table_prefix . "_feeds` SET `feed_last_check` = FROM_UNIXTIME(" . (time()-300) . ") WHERE `feed_id` = $feed->feed_id;";

NG: table_prefix . "_feeds`
OK: table_prefix . "feeds`